FreeBasic
Главная
Вход
Регистрация
Пятница, 16.04.2021, 01:34Приветствую Вас Гость | RSS
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » Вспомогательное программное обеспечение » Вспомогательные утилиты для программистов » поддержка кириллицы в wxFBE
поддержка кириллицы в wxFBE
mashakovmaratДата: Четверг, 27.06.2019, 20:47 | Сообщение # 1
Сержант
Группа: Пользователи
Сообщений: 36
Репутация: 0
Статус: Offline
Добрый день.

На этой доске находил пост о поддержке wxFBE кириллицы, но ссылка уже "неживая".
У меня Linux Debian.
Есть ли какой патч для нормальной поддержки кириллицы в wxFBE? После открытия ранее сохраненных фалов вся кириллица превращается в кракозябры. Глаз режет.
Просто часть "работы" делаю на FBEdit, а когда пересаживаюсь с этим кодом на Linux, то wxFBE "огорчает".
Да и если при редакции в самом wxFBE ввести русскоязычный комментарий, после открытия он нечитаем.
Но, если открыть файл, например в Mousepad, сделать русский комментарий, то он остается русским читаемым и при открытии в wxFBE. Но это до первого сохранения через wxFBE. Потом уже этот же комментарий будет нечитаемым.
 
haavДата: Пятница, 28.06.2019, 08:05 | Сообщение # 2
Генерал-полковник
Группа: Администраторы
Сообщений: 1066
Репутация: 43
Статус: Offline
Я занимался этим редактором несколько лет назад и даже определенную часть проблем на Linux с русификацией решил, однако найти проект не могу. Наверное после создания своего редактора , надобность в wxfbe отпала и я возможно просто удалил папку. На самом деле жалеть не о чем , кроме проблем с русификацией в wxfbe еще очень много багов. Редактор не был популярным , а автор по понятным причинам все ошибки сам обнаружить не мог. В данный момент можно считать редактор заброшенным, потому что автора я давно не видел на оф. форуме. Даже если автор появится , вряд ли он начнет заниматься проектом многолетней давности. 

Я советую под Linux для FB эти редакторы:

IUP_FB_EDITOR - редактор , написанный мною
POSEIDON - полноценная IDE , наверное лучшая 
GEANY - популярный редактор под разные языки и не только


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
mashakovmaratДата: Пятница, 28.06.2019, 17:06 | Сообщение # 3
Сержант
Группа: Пользователи
Сообщений: 36
Репутация: 0
Статус: Offline
haav, спасибо.
Попробую.

Добавлено (29.06.2019, 12:32)
---------------------------------------------
haav, а есть ли варианты для удобной редакции из консоли? Я в плане, чтобы была поддержка FreeBASIC.
Сейчас использую nano.

 
haavДата: Суббота, 29.06.2019, 13:29 | Сообщение # 4
Генерал-полковник
Группа: Администраторы
Сообщений: 1066
Репутация: 43
Статус: Offline
Цитата mashakovmarat ()
haav, а есть ли варианты для удобной редакции из консоли? Я в плане, чтобы была поддержка FreeBASIC.Сейчас использую nano.


Всегда считал , что консольные редакторы вроде nano , vim предназначены больше для редактирования конфигов , нежели для кодинга. Под FB не знаю таких вариантов.  Даже если и есть такой вариант, в чем преимущество их перед GUI?  В нежелании\лени\неумении ставить необходимые библиотеки для gui редактора? Допустим редактор nano хорош тем , что его можно установить и запустить имея практически "голый" Linux для крохотных правок из терминала. Редактор vim конечно очень серьезный инструмент , я даже допускаю что кто нибудь возможно сделал какой нибудь плагин для него , но не думаю что в нем будет удобнее работать чем в редакторах, написанных специально для FB.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
mashakovmaratДата: Воскресенье, 30.06.2019, 16:52 | Сообщение # 5
Сержант
Группа: Пользователи
Сообщений: 36
Репутация: 0
Статус: Offline
haav, добрый день.

Запускаю fbnp (iup_fb_editor), но "ругается", просит libuip (error while loading shared libraries: libiup.so: cannot open shared object file: No such file or directory).
На https://sourceforge.net/projects/iup/files/ последняя версия 3.27.
Какую версию лучше скачать?
Чего то там в списках одни 64 бита.

P.S. автоматом скачал 3.27, распаковал, запустил скрипт install, но опять "ругается" - cp: не удалось выполнить stat для 'libiup*.so': Нет такого файла или каталога.
Странно, в нем самом нет libuip.

P.S. Не обращал ранее внимания, но, во всяком случае сейчас, в /usr/local/include/freebasic/ есть директория IUP с библиотеками .bi. Наверное, это к iup_fb_editor отношения не имеет.


Сообщение отредактировал mashakovmarat - Воскресенье, 30.06.2019, 17:35
 
haavДата: Воскресенье, 30.06.2019, 17:23 | Сообщение # 6
Генерал-полковник
Группа: Администраторы
Сообщений: 1066
Репутация: 43
Статус: Offline
Для Linux 32-bit последняя скомпилированная версия 3.21: https://sourceforge.net/project....ownload
В папке help редактора есть файл: helpEditorRU.html , в нем кое-что написано.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
mashakovmaratДата: Воскресенье, 30.06.2019, 17:36 | Сообщение # 7
Сержант
Группа: Пользователи
Сообщений: 36
Репутация: 0
Статус: Offline
Цитата haav ()
Для Linux 32-bit последняя скомпилированная версия 3.21: https://sourceforge.net/project....ownloadВ папке help редактора есть файл: helpEditorRU.html , в нем кое-что написано.


ок. спасибо.

Действительно, весьма полезный файл helpEditorRU.html )))
Доустановил все что прописано. Редактор, во всяком случае, запустился.

Спасибо.


Сообщение отредактировал mashakovmarat - Воскресенье, 30.06.2019, 18:08
 
haavДата: Воскресенье, 30.06.2019, 19:33 | Сообщение # 8
Генерал-полковник
Группа: Администраторы
Сообщений: 1066
Репутация: 43
Статус: Offline
Вот здесь часть исходника я прилагал с исправлениями и дополнениями. Если будет желание собрать из исходника редактор , то нужно будет скачать исходники с sf.net , распаковать,  а потом из архива заменить файлы. Для сборки придется установить необходимые библиотеки: libgtk2.0-dev и может еще какие. В общем будет желание и если появятся проблемы при сборке, пиши. У меня все как-то не доходят руки выпустить официальное исправление.

Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
Форум » Вспомогательное программное обеспечение » Вспомогательные утилиты для программистов » поддержка кириллицы в wxFBE
  • Страница 1 из 1
  • 1
Поиск: