FreeBasic
Главная
Вход
Регистрация
Воскресенье, 03.03.2024, 15:44Приветствую Вас Гость | RSS
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 2
  • 1
  • 2
  • »
Форум » Библиотеки для FreeBasic » Библиотека Window9 для Freebasic » window9 в репозитории AltLinux
window9 в репозитории AltLinux
useful630Дата: Вторник, 27.09.2022, 16:45 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
К приятному удивлению свежий FB есть в реп. Альта.
И сопровождающий на связи.
Сегодня вот по правили зависимости, не хватало libtinfo-devel, за одно и libncurses-devel в соответствие с рекомендациями
The FreeBASIC compiler (fbc) and the executable generated by it depend on libc, libm, libpthread, libdl and libncurses.
Без tinfo не собирался hello.bas обычно она с кем нибудь по зависимостям прилетает, но я столкнулся на чистой системе.
https://git.altlinux.org/tasks/archive/done/_300/307454/

А теперь о главном. Есть заинтересованность включить w9 в sisyphus?

За одно по тренироваться в создании спека для пакетов разработанных на FB.
А то инструмент в репозитории есть, а разработок на нём нет.
В свете рекламной компании https://www.basealt.ru/simplylinux/ было бы интересно.
 
haavДата: Среда, 28.09.2022, 07:11 | Сообщение # 2
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Одной заинтересованности как я понимаю мало? Нужно будет мне все самому настроить , собрать в RPM пакет , протестировать?
Я никогда не занимался сборкой всех этих пакетов (хоть deb , хоть rpm). И не уверен , что хочу этим заниматься. Я даже не уверен , что альтлинукс имеет на борту все зависимости для w9.
Как-то несколько лет назад я пробовал ставить FB и свою либу на разные системы. Где-то это было легко , как в дебиан совместимых. Где-то чуть сложнее , как в opensuse , fedora. А где-то кажется установка вообще не удалась. И кажется это был альтлинукс (хотя я не уверен). Это не значит , что туда совсем нельзя было поставить , просто часто не хватало нужных пакетов.
Но если кто-то сам захочет воткнуть мою либу в оф. репу альта (собрать rpm пакет) , то да я заинтересован очень сильно smile


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
haavДата: Среда, 28.09.2022, 08:44 | Сообщение # 3
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Установил симпли линукс и попробовал воткнуть туда fbc. И вот что получилось:



не знаю , как там у вас заработало , тут как минимум проблема совместимости glibc.
Поэтому я и люблю дебиан совместимые системы. У них всегда все есть , все ставится с полпинка. А если чего-то убирают из новых версий , можно вытянуть пакеты из старых версий.
Прикрепления: 7950313.png (40.2 Kb)


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 08:48 | Сообщение # 4
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline

Будем считать, что нас пока будет трое. Андрей Черепанов из Альта который по своей инициативе сопровождает FB в репах альта, Вы и я мимо проходящий интересующийся.
Желающий для себя и так может использовать библиотеку. Для меня это стимул разобраться с написанием спека пакетов на FB под альт. Повод хороший.
Если найдём общий язык думаю Андрей просто прибавит себе ещё пакет в список сопровождаемых или кто другой подключится.

p.s. И да. Спокойно, вдумчиво, не торопясь, по мере сил и здоровья.
p.p.s. Ещё бы найти обладателей aarch64,armh и до кучи ppc64le smile  для тестов. Сам FB автоматом судя по протоколам сборки есть под 5 платформ в Альте.

Добавлено (28.09.2022, 08:54)
---------------------------------------------
Цитата haav ()
Установил симпли линукс и попробовал воткнуть туда fbc. И вот что получилось:

Не понял. Есть в репозитории. Синаптик поиск freebasic и уже несколько лет.
Сейчас только libncurses-devel нужно добавлять. Правка ещё не дошла до p10, только в сизифе.

Добавлено (28.09.2022, 09:15)
---------------------------------------------

Цитата haav ()
Я даже не уверен , что альтлинукс имеет на борту все зависимости для w9.
100% имеет. У меня даже последний purebasic 6.0 на 10-й платформе работает лучше чем на ubuntu/debian например Фред 32х разряднeю версию оставил только для deb10 и она прекрасно работает на 32-разрядной Симпли.
Прикрепления: 9481540.png (978.5 Kb)


Сообщение отредактировал useful630 - Среда, 28.09.2022, 09:03
 
haavДата: Среда, 28.09.2022, 09:59 | Сообщение # 5
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Я качал rpm пакет по ссылке , которая указана в первом посте и пробовал ставить вручную. Не знаю , почему так получилось , вроде версию качал нужную...
Я даже не думал , что в альте есть синаптик smile
А разбираться , как в альте ставить из терминала (какой там менеджер) я не стал. Синаптик все упрощает для меня , желающего с наскока проверить что-то там в альте.

Да , действительно в альте все присутствует , что необходимо для работы с моей либой. Даже первый вебкит есть , что дает возможность использовать w9 с gtk2. Я для теста попробовал версию w9 с gtk3 , и все работает без проблем.
Так же без проблем установил свой редактор IUP_FB_EDITOR.

Только я не пойму , что от меня-то требуется? Составлять пакеты я не умею , так что помощник из меня никудышный.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 10:12 | Сообщение # 6
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
Если личной заинтересованности разобраться в https://www.altlinux.org/Технология_сборки_пакетов_RPM не наблюдается, то ничего и не требуется. )))
Буду по немногу разбираться сам, Андрей подскажет. Будут вопросы по библиотеке задам.
Захочет Андрей или кто другой взять пакет на сопровождение, появится он в репозитории.
Не появится, мир не рухнет, мой интерес - интерес мимо проходящего обнаружившего постоянно сопровождаемый FB в Альте и знающий о существовании W9, уровня - почему бы нет! cool


Сообщение отредактировал useful630 - Среда, 28.09.2022, 10:18
 
haavДата: Среда, 28.09.2022, 10:43 | Сообщение # 7
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Цитата useful630 ()
Будут вопросы по библиотеке задам.

Вот тут помогу , чем смогу. А лезть в дебри RPM или DEB точно не хочу.

Я тут посмотрел , оказывается альт использует APT для пакетов. Так что для установки W9 (GTK3) достаточно этого:

Цитата
sudo cp libwindow9.a /usr/lib/freebasic/linux-x86_64/
sudo cp *.bi /usr/include/freebasic/
sudo apt-get install libGLU-devel libgtk+3-devel
sudo ln libwebkit2gtk-4.0.so.37.53.5 libwebkit2gtk-3.0.so


Для W9(GTK2) скорее всего просто (хоть я и не проверял):

Цитата
sudo cp libwindow9.a /usr/lib/freebasic/linux-x86_64/
sudo cp *.bi /usr/include/freebasic/
sudo apt-get install libGLU-devel libgtk+2-devel

Ну и конечно libwindow9.a нужно выбирать соответствующую (для определенной версии GTK) из архива. А в файле window9.bi для GTK3 раскомментировать строку: '#define __USE_GTK3__


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 10:59 | Сообщение # 8
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
Это понятно.
Но начинать то нужно из далека.
Нужно подготовить source RPM, который робот будет собирать и тестировать libwindow9.a под все платформы. (как минимум 4, 2x86 и 2ARM)
А уже из него бинарный пакет.
Короче гимнастика для профилактики деменции smile

p.s. в январе следующего года будет 40 лет как была написана первая программа, которой кто то пользовался кроме меня и волею случая отладчик был самый удобный в моей жизни


Сообщение отредактировал useful630 - Среда, 28.09.2022, 11:00
 
haavДата: Среда, 28.09.2022, 11:26 | Сообщение # 9
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Цитата useful630 ()
libwindow9.a под все платформы. (как минимум 4, 2x86 и 2ARM)

W9 работает только под x86 и x86-64.
С ARM я не знаком и понятия не имею , что там и как будет работать. Устройств таких не имею , проверить даже fbc не могу.

Цитата
урал 11

емае какая древность , так тебе наверное 60+ лет? Чтобы на таком работать , надо было родиться еще при Хрущеве.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 11:49 | Сообщение # 10
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
Всего 61, родился ещё в Сталинграде, в год переименования, а Урал застал умирающим в 83-м, через пару лет его же разбирал, хоронил, поминал вот в этом доме
Я ещё зарплату получал за изучение Днепр22, и даже два раза видел как его включали smile


Добавлено (28.09.2022, 11:52)
---------------------------------------------
Цитата haav ()
W9 работает только под x86 и x86-64.
Думаю проблем не будет. PB6 с новым gcc бакэндом прекрасно переехал на ARM

https://sourceforge.net/project....spbian9


Сообщение отредактировал useful630 - Среда, 28.09.2022, 11:55
 
haavДата: Среда, 28.09.2022, 12:23 | Сообщение # 11
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Цитата useful630 ()
Я ещё зарплату получал за изучение Днепр22, и даже два раза видел как его включали

Круто. Это ведь наверное еще ламповые агрегаты?
Потребляют 4 квт - нормальные такие калькуляторы и для подсчета и для подогрева одновременно smile Хотя там наверное вентиляция была на уровне.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 12:44 | Сообщение # 12
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
С подогревом это в точку. Днепр я впервые увидел на бывшем берегу бывшего Арала (к этому моменту уже 40км до воды, а когда то объект на самом берегу был, до него катером добирались.)
Зима, мороз, помещение с порушенным отоплением, мы в валенках, ватных штанах и куртках. К обеду куртку можно было снять.
А перед тем домом что на фото (другую что то не нахожу) четыре круглых бассейна-фонтана системы централизованного охлаждения здания.
https://computer-museum.ru/histussr/ural11.htm
Ещё я видел у подножья Ключевской сопки глаза программиста, которому перед каждым испытанием нужно было компилировать программу на фортране для Урала.
Казалось бы, чего такого? Дело в том, что барабаны уже рассыпались, только ленты, для успеха нужно было, что бы исправно отработали 5 лентопротяжек и летна ни на одной из них не замялась.
Нашёл в таком виде https://www.etoretro.ru/pic5041....rt=DESC


Сообщение отредактировал useful630 - Среда, 28.09.2022, 12:56
 
haavДата: Среда, 28.09.2022, 12:58 | Сообщение # 13
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
Хотя нашел инфу , что днепр уже на полупроводниках был собран. И всего-то 10 000 операций в секунду.
Хотя ламповый уже десятками киловатт пожирал. Вот например https://ru.wikipedia.org/wiki....%D0%B0) :  50квт жрал. 20 тыс. операций в секунду , даже круче чем полупроводниковый днепр.


Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
haavДата: Среда, 28.09.2022, 13:14 | Сообщение # 14
Генералиссимус
Группа: Администраторы
Сообщений: 1360
Репутация: 49
Статус: Offline
А че хоть за программы писались на уралах? Что-то подсоединялось к уралам (там станки например)? Ну то есть , что из программ имело реальную практическую ценность?

Вы сохраняете власть над людьми покуда оставляете им что-то…Отберите у человека все, и этот человек уже будет неподвластен вам…
 
useful630Дата: Среда, 28.09.2022, 13:38 | Сообщение # 15
Рядовой
Группа: Пользователи
Сообщений: 19
Репутация: 0
Статус: Offline
Телеметрия, но не в современном понимании. Стояли телеметрические магнитофоны без старт-стопа. Для них готовили ленты на других спецмашинах снимая шифровку принятого с борта изделия (РВСН)
Уралы должны были по спец заданию нужное забрать с ленты на проходе для оформления в виде таблиц АЦПУ и графиков на рулонах электрохимической бумаги.
Весь кадр забирать было некуда, по разным заданиям ленту крутили много раз.
Потом такие же магнитофоны присоединили к ЕС-1045.
На Камчатке сейсмодатчики в реальном режиме для получения точки падения (поэтому математика фортран), куда и по сей день с Плесецка пуляют.
Что примечательно магнитофоны были морского базирования на пружинах, его толкнёшь, он качается а лента крутится.

p.s. И кстати уже на 1045 асинхронным вводом выводом и распараллеливанием я объелся в середине 80х прошлого века, поэтому сейчас тихо улыбаюсь читая всякие "свежие" новости про асинхронность и параллельность.

Добавлено (28.09.2022, 14:05)
---------------------------------------------
По вспоминать я люблю, но вернёмся к теме. Забываю спросить про
-gen gas|gas64|gcc|llvm  Select code generation backend
Я правильно понимаю, что библиотека по мимо архитектуры, разрядности, тулкита 2/3, ещё и для каждого бакэнда нужна?
Мои эксперименты под Альт на первый взгляд показывают, что по умолчанию не gas, как я где то встречал в документации, а как раз gcc,
а там ещё и оптимизацию включать можно.


Сообщение отредактировал useful630 - Среда, 28.09.2022, 14:08
 
Форум » Библиотеки для FreeBasic » Библиотека Window9 для Freebasic » window9 в репозитории AltLinux
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск: